use strict;
my $str = 'file:///Users/john.smith/Projects/joehall-logo-256x256.png
/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip
/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
../../assets/android-chrome-512x512.png
./android-chrome-512x512.png
android-chrome-512x512.png';
my $regex = qr/(?=~\/|\.\/|\..\/|\/|file:\/\/\/|\w)[\w\-\._\(\)\[\] ]+$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}