import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=~\\/|\\.\\/|\\..\\/|\\/|file:\\/\\/\\/|\\w)[\\w\\-\\._\\(\\)\\[\\] ]+$";
final String string = "file:///Users/john.smith/Projects/joehall-logo-256x256.png\n"
+ "/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip\n"
+ "/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png\n"
+ "~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png\n"
+ "../../assets/android-chrome-512x512.png\n"
+ "./android-chrome-512x512.png\n"
+ "android-chrome-512x512.png";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}