using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=~\/|\.\/|\..\/|\/|file:\/\/\/|\w)[\w\-\._\(\)\[\] ]+$";
string input = @"file:///Users/john.smith/Projects/joehall-logo-256x256.png
/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip
/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
../../assets/android-chrome-512x512.png
./android-chrome-512x512.png
android-chrome-512x512.png";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}