re = /\A(?# String begin)([\*])?(?# Optional * at begin)([[:word:][:blank:][!"#$%£¥#%@€&'()+,\-.\/:;<=>?@[\]^_`{|}~§üäöÜÄÖ]]*)(?# match characters allowed as search string - no * in here!){3,}?(?# at least 3 characters, non greedy)([\*])?(?# optional * at end)\Z(?# end of string)/
str = '*SomeT?=)(/&%$"!123423AndSomeMore*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end