#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\A(?# String begin)([\*])?(?# Optional * at begin)([[:word:][:blank:][!"#$%£¥#%@€&'()+,\-.\/:;<=>?@[\]^_`{|}~§üäöÜÄÖ]]*)(?# match characters allowed as search string - no * in here!){3,}?(?# at least 3 characters, non greedy)([\*])?(?# optional * at end)\Z(?# end of string)"
Local $sString = "*SomeT?=)(/&%$"!123423AndSomeMore*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")