import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?# String begin)([\\*])?(?# Optional * at begin)([[:word:][:blank:][!\"#$%£¥#%@€&'()+,\\-.\\/:;<=>?@[\\]^_`\\{|\\}~§üäöÜÄÖ]]*)(?# match characters allowed as search string - no * in here!){3,}?(?# at least 3 characters, non greedy)([\\*])?(?# optional * at end)\\Z(?# end of string)";
final String string = "*SomeT?=)(/&%$\"!123423AndSomeMore*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}