$re = '/\A(?# String begin)([\*])?(?# Optional * at begin)([[:word:][:blank:][!"#$%£¥#%@€&\'()+,\-.\/:;<=>?@[\]^_`{|}~§üäöÜÄÖ]]*)(?# match characters allowed as search string - no * in here!){3,}?(?# at least 3 characters, non greedy)([\*])?(?# optional * at end)\Z(?# end of string)/';
$str = '*SomeT?=)(/&%$"!123423AndSomeMore*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);