using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A(?# String begin)([\*])?(?# Optional * at begin)([[:word:][:blank:][!""#$%£¥#%@€&'()+,\-.\/:;<=>?@[\]^_`{|}~§üäöÜÄÖ]]*)(?# match characters allowed as search string - no * in here!){3,}?(?# at least 3 characters, non greedy)([\*])?(?# optional * at end)\Z(?# end of string)";
string input = @"*SomeT?=)(/&%$""!123423AndSomeMore*";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}