package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A(?# String begin)([\*])?(?# Optional * at begin)([[:word:][:blank:][!"#$%£¥#%@€&'()+,\-.\/:;<=>?@[\]^_`{|}~§üäöÜÄÖ]]*)(?# match characters allowed as search string - no * in here!){3,}?(?# at least 3 characters, non greedy)([\*])?(?# optional * at end)\Z(?# end of string)`)
var str = `*SomeT?=)(/&%$"!123423AndSomeMore*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}