import Foundation
let pattern = #"(?<!\.)\b\$?[1-9]\d*\.\d{2}\b(?!\.\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
12.34 56.78.90.12 34.56
123.45. 345.67. 912.23
$98.76
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)