const regex = /(?<!\.)\b\$?[1-9]\d*\.\d{2}\b(?!\.\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\.)\\b\\$?[1-9]\\d*\\.\\d{2}\\b(?!\\.\\d)', 'g')
const str = `12.34 56.78.90.12 34.56
123.45. 345.67. 912.23
\$98.76
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}