use strict;
my $str = '12.34 56.78.90.12 34.56
123.45. 345.67. 912.23
$98.76
';
my $regex = qr/(?<!\.)\b\$?[1-9]\d*\.\d{2}\b(?!\.\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}