import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\.)\\b\\$?[1-9]\\d*\\.\\d{2}\\b(?!\\.\\d)";
final String string = "12.34 56.78.90.12 34.56\n\n"
+ "123.45. 345.67. 912.23\n\n"
+ "$98.76\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}