$re = '/(?<!\.)\b\$?[1-9]\d*\.\d{2}\b(?!\.\d)/';
$str = '12.34 56.78.90.12 34.56
123.45. 345.67. 912.23
$98.76
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);