using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\.)\b\$?[1-9]\d*\.\d{2}\b(?!\.\d)";
string input = @"12.34 56.78.90.12 34.56
123.45. 345.67. 912.23
$98.76
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}