import Foundation
let pattern = #"^([0-3]($|\.)|4.(0|[0-9]($|\.))|4\.10\.190[0-3])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
4.10.19041401
4.10.190
4.9
4.0.
4.9.
3
3.
30
^([0-3]|4.(0|([0-9]\.))|4\.10\.190[0-3])
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)