$re = '/^([0-3]($|\.)|4.(0|[0-9]($|\.))|4\.10\.190[0-3])/m';
$str = '4.10.19041401
4.10.190
4.9
4.0.
4.9.
3
3.
30
^([0-3]|4.(0|([0-9]\\.))|4\\.10\\.190[0-3])
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);