import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-3]($|\\.)|4.(0|[0-9]($|\\.))|4\\.10\\.190[0-3])";
final String string = "4.10.19041401\n"
+ "4.10.190\n"
+ "4.9\n"
+ "4.0.\n"
+ "4.9.\n"
+ "3\n"
+ "3.\n"
+ "30\n\n"
+ " \n"
+ "^([0-3]|4.(0|([0-9]\\.))|4\\.10\\.190[0-3])\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}