#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-3]($|\.)|4.(0|[0-9]($|\.))|4\.10\.190[0-3])"
Local $sString = "4.10.19041401" & @CRLF & _
"4.10.190" & @CRLF & _
"4.9" & @CRLF & _
"4.0." & @CRLF & _
"4.9." & @CRLF & _
"3" & @CRLF & _
"3." & @CRLF & _
"30" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"^([0-3]|4.(0|([0-9]\.))|4\.10\.190[0-3])" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")