package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-3]($|\.)|4.(0|[0-9]($|\.))|4\.10\.190[0-3])`)
var str = `4.10.19041401
4.10.190
4.9
4.0.
4.9.
3
3.
30
^([0-3]|4.(0|([0-9]\.))|4\.10\.190[0-3])
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}