re = /^([0-3]($|\.)|4.(0|[0-9]($|\.))|4\.10\.190[0-3])/m
str = '4.10.19041401
4.10.190
4.9
4.0.
4.9.
3
3.
30
^([0-3]|4.(0|([0-9]\\.))|4\\.10\\.190[0-3])
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end