import Foundation
let pattern = #"<field>[\s\S]+?(?=<\/field>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<field>
<item value="1" description="Mostly A's" />
<item value="2" description="Mostly B's" />
<item value="3" description="Mostly C's" />
<item value="4" description="Mostly D's" />
<item value="5" description="Mostly failures" />
<item value="6" description="Mostly incompletes" />
<item value="7" description="Not applicable" />
</field>
<field>
<item value="1" description="Mostly A's" />
<item value="2" description="Mostly B's" />
<item value="3" description="Mostly C's" />
<item value="4" description="Mostly D's" />
<item value="5" description="Mostly failures" />
<item value="6" description="Mostly incompletes" />
<item value="7" description="Not applicable" />
</field>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)