const regex = /<field>[\s\S]+?(?=<\/field>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<field>[\\s\\S]+?(?=<\\\/field>)', 'gm')
const str = `<field>
<item value="1" description="Mostly A's" />
<item value="2" description="Mostly B's" />
<item value="3" description="Mostly C's" />
<item value="4" description="Mostly D's" />
<item value="5" description="Mostly failures" />
<item value="6" description="Mostly incompletes" />
<item value="7" description="Not applicable" />
</field>
<field>
<item value="1" description="Mostly A's" />
<item value="2" description="Mostly B's" />
<item value="3" description="Mostly C's" />
<item value="4" description="Mostly D's" />
<item value="5" description="Mostly failures" />
<item value="6" description="Mostly incompletes" />
<item value="7" description="Not applicable" />
</field>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}