#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<field>[\s\S]+?(?=<\/field>)"
Local $sString = "<field>" & @CRLF & _
"<item value="1" description="Mostly A's" />" & @CRLF & _
"<item value="2" description="Mostly B's" />" & @CRLF & _
"<item value="3" description="Mostly C's" />" & @CRLF & _
"<item value="4" description="Mostly D's" />" & @CRLF & _
"<item value="5" description="Mostly failures" />" & @CRLF & _
"<item value="6" description="Mostly incompletes" />" & @CRLF & _
"<item value="7" description="Not applicable" />" & @CRLF & _
"</field>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<field>" & @CRLF & _
"<item value="1" description="Mostly A's" />" & @CRLF & _
"<item value="2" description="Mostly B's" />" & @CRLF & _
"<item value="3" description="Mostly C's" />" & @CRLF & _
"<item value="4" description="Mostly D's" />" & @CRLF & _
"<item value="5" description="Mostly failures" />" & @CRLF & _
"<item value="6" description="Mostly incompletes" />" & @CRLF & _
"<item value="7" description="Not applicable" />" & @CRLF & _
"</field>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")