# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<field>[\s\S]+?(?=<\/field>)"
test_str = ("<field>\n"
"<item value=\"1\" description=\"Mostly A's\" />\n"
"<item value=\"2\" description=\"Mostly B's\" />\n"
"<item value=\"3\" description=\"Mostly C's\" />\n"
"<item value=\"4\" description=\"Mostly D's\" />\n"
"<item value=\"5\" description=\"Mostly failures\" />\n"
"<item value=\"6\" description=\"Mostly incompletes\" />\n"
"<item value=\"7\" description=\"Not applicable\" />\n"
"</field>\n\n\n"
"<field>\n"
"<item value=\"1\" description=\"Mostly A's\" />\n"
"<item value=\"2\" description=\"Mostly B's\" />\n"
"<item value=\"3\" description=\"Mostly C's\" />\n"
"<item value=\"4\" description=\"Mostly D's\" />\n"
"<item value=\"5\" description=\"Mostly failures\" />\n"
"<item value=\"6\" description=\"Mostly incompletes\" />\n"
"<item value=\"7\" description=\"Not applicable\" />\n"
"</field>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.