using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<field>[\s\S]+?(?=<\/field>)";
string input = @"<field>
<item value=""1"" description=""Mostly A's"" />
<item value=""2"" description=""Mostly B's"" />
<item value=""3"" description=""Mostly C's"" />
<item value=""4"" description=""Mostly D's"" />
<item value=""5"" description=""Mostly failures"" />
<item value=""6"" description=""Mostly incompletes"" />
<item value=""7"" description=""Not applicable"" />
</field>
<field>
<item value=""1"" description=""Mostly A's"" />
<item value=""2"" description=""Mostly B's"" />
<item value=""3"" description=""Mostly C's"" />
<item value=""4"" description=""Mostly D's"" />
<item value=""5"" description=""Mostly failures"" />
<item value=""6"" description=""Mostly incompletes"" />
<item value=""7"" description=""Not applicable"" />
</field>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}