import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<field>[\\s\\S]+?(?=<\\/field>)";
final String string = "<field>\n"
+ "<item value=\"1\" description=\"Mostly A's\" />\n"
+ "<item value=\"2\" description=\"Mostly B's\" />\n"
+ "<item value=\"3\" description=\"Mostly C's\" />\n"
+ "<item value=\"4\" description=\"Mostly D's\" />\n"
+ "<item value=\"5\" description=\"Mostly failures\" />\n"
+ "<item value=\"6\" description=\"Mostly incompletes\" />\n"
+ "<item value=\"7\" description=\"Not applicable\" />\n"
+ "</field>\n\n\n"
+ "<field>\n"
+ "<item value=\"1\" description=\"Mostly A's\" />\n"
+ "<item value=\"2\" description=\"Mostly B's\" />\n"
+ "<item value=\"3\" description=\"Mostly C's\" />\n"
+ "<item value=\"4\" description=\"Mostly D's\" />\n"
+ "<item value=\"5\" description=\"Mostly failures\" />\n"
+ "<item value=\"6\" description=\"Mostly incompletes\" />\n"
+ "<item value=\"7\" description=\"Not applicable\" />\n"
+ "</field>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}