// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^Subject:\s*([^=].*)\s*([^=].*)").unwrap();
let string = "Subject:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Topic:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}