import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Subject:\\s*([^=].*)\\s*([^=].*)";
final String string = "Subject:\n"
+ " =?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=\n"
+ " =?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=\n"
+ "Thread-Topic:\n"
+ " =?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=\n"
+ " =?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=\n"
+ "Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}