$re = '/^Subject:\s*([^=].*)\s*([^=].*)/';
$str = 'Subject:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Topic:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);