package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^Subject:\s*([^=].*)\s*([^=].*)`)
var str = `Subject:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Topic:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}