#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^Subject:\s*([^=].*)\s*([^=].*)"
Local $sString = "Subject:" & @CRLF & _
" =?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=" & @CRLF & _
" =?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=" & @CRLF & _
"Thread-Topic:" & @CRLF & _
" =?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=" & @CRLF & _
" =?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=" & @CRLF & _
"Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")