const regex = new RegExp('^Subject:\\s*([^=].*)\\s*([^=].*)', '')
const str = `Subject:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Topic:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}