re = /(pty|ltd|trust|incorporated|npc|association|npo|corporation|limited|foundation|soe)|(close).*(corp)|(corp).*(close)|[\W\s\d]+(cc|inc)[\W\s\d]+|[\w\D]+(cc|inc)[^a-zA-Z\s]+|[^a-zA-Z\s]+(cc|inc)[\w\D]+|^(cc|inc)[\W\s\d]+|[\W\s\d]+(cc|inc)$|^(cc|inc)$/mi
str = '"Sen Do INC","Sen Do INC",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end