package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(pty|ltd|trust|incorporated|npc|association|npo|corporation|limited|foundation|soe)|(close).*(corp)|(corp).*(close)|[\W\s\d]+(cc|inc)[\W\s\d]+|[\w\D]+(cc|inc)[^a-zA-Z\s]+|[^a-zA-Z\s]+(cc|inc)[\w\D]+|^(cc|inc)[\W\s\d]+|[\W\s\d]+(cc|inc)$|^(cc|inc)$`)
var str = `"Sen Do INC","Sen Do INC",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}