const regex = new RegExp('(pty|ltd|trust|incorporated|npc|association|npo|corporation|limited|foundation|soe)|(close).*(corp)|(corp).*(close)|[\\W\\s\\d]+(cc|inc)[\\W\\s\\d]+|[\\w\\D]+(cc|inc)[^a-zA-Z\\s]+|[^a-zA-Z\\s]+(cc|inc)[\\w\\D]+|^(cc|inc)[\\W\\s\\d]+|[\\W\\s\\d]+(cc|inc)$|^(cc|inc)$', 'mig')
const str = `"Sen Do INC","Sen Do INC",`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}