import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(pty|ltd|trust|incorporated|npc|association|npo|corporation|limited|foundation|soe)|(close).*(corp)|(corp).*(close)|[\\W\\s\\d]+(cc|inc)[\\W\\s\\d]+|[\\w\\D]+(cc|inc)[^a-zA-Z\\s]+|[^a-zA-Z\\s]+(cc|inc)[\\w\\D]+|^(cc|inc)[\\W\\s\\d]+|[\\W\\s\\d]+(cc|inc)$|^(cc|inc)$";
final String string = "\"Sen Do INC\",\"Sen Do INC\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}