use strict;
my $str = '"Sen Do INC","Sen Do INC",';
my $regex = qr/(pty|ltd|trust|incorporated|npc|association|npo|corporation|limited|foundation|soe)|(close).*(corp)|(corp).*(close)|[\W\s\d]+(cc|inc)[\W\s\d]+|[\w\D]+(cc|inc)[^a-zA-Z\s]+|[^a-zA-Z\s]+(cc|inc)[\w\D]+|^(cc|inc)[\W\s\d]+|[\W\s\d]+(cc|inc)$|^(cc|inc)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}