using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(pty|ltd|trust|incorporated|npc|association|npo|corporation|limited|foundation|soe)|(close).*(corp)|(corp).*(close)|[\W\s\d]+(cc|inc)[\W\s\d]+|[\w\D]+(cc|inc)[^a-zA-Z\s]+|[^a-zA-Z\s]+(cc|inc)[\w\D]+|^(cc|inc)[\W\s\d]+|[\W\s\d]+(cc|inc)$|^(cc|inc)$";
string input = @"""Sen Do INC"",""Sen Do INC"",";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}