// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(?\b([0-9]{3})\)?([0-9]{3})?([0-9]{4})\b").unwrap();
let string = "1234567890
99999999999999
hello world1234567890
123-456-7890
0123456789
123.456.7890
123 456 7890
8054448445
3104448445
8187558094
310
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}