#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(?\b([0-9]{3})\)?([0-9]{3})?([0-9]{4})\b"
Local $sString = "1234567890" & @CRLF & _
"99999999999999" & @CRLF & _
"hello world1234567890" & @CRLF & _
"123-456-7890" & @CRLF & _
"0123456789" & @CRLF & _
"123.456.7890" & @CRLF & _
"123 456 7890" & @CRLF & _
"8054448445" & @CRLF & _
"3104448445" & @CRLF & _
"8187558094" & @CRLF & _
"310 " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")