use strict;
my $str = '1234567890
99999999999999
hello world1234567890
123-456-7890
0123456789
123.456.7890
123 456 7890
8054448445
3104448445
8187558094
310
';
my $regex = qr/\(?\b([0-9]{3})\)?([0-9]{3})?([0-9]{4})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}