package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(?\b([0-9]{3})\)?([0-9]{3})?([0-9]{4})\b`)
var str = `1234567890
99999999999999
hello world1234567890
123-456-7890
0123456789
123.456.7890
123 456 7890
8054448445
3104448445
8187558094
310
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}