const regex = /\(?\b([0-9]{3})\)?([0-9]{3})?([0-9]{4})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(?\\b([0-9]{3})\\)?([0-9]{3})?([0-9]{4})\\b', 'gm')
const str = `1234567890
99999999999999
hello world1234567890
123-456-7890
0123456789
123.456.7890
123 456 7890
8054448445
3104448445
8187558094
310
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}