import Foundation
let pattern = #"([a-zA-Z0-9_]+)\s?(\([a-zA-Z0-9_\s,*]*\))?\s?\{\s?(.*)\s?\}\s?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ShortCode_block (*args){expresion}
CodeBlock (param1, param2) {
return param1 + param2
}
no_parenthesis_codeblock {
# this code block doesnt use parentheses
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)