import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_]+)\\s?(\\([a-zA-Z0-9_\\s,*]*\\))?\\s?\\{\\s?(.*)\\s?\\}\\s?";
final String string = "ShortCode_block (*args){expresion}\n\n"
+ "CodeBlock (param1, param2) {\n"
+ " return param1 + param2\n"
+ "}\n\n"
+ "no_parenthesis_codeblock {\n"
+ " # this code block doesnt use parentheses\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}