$re = '/([a-zA-Z0-9_]+)\s?(\([a-zA-Z0-9_\s,*]*\))?\s?\{\s?(.*)\s?\}\s?/m';
$str = 'ShortCode_block (*args){expresion}
CodeBlock (param1, param2) {
return param1 + param2
}
no_parenthesis_codeblock {
# this code block doesnt use parentheses
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);