#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9_]+)\s?(\([a-zA-Z0-9_\s,*]*\))?\s?\{\s?(.*)\s?\}\s?"
Local $sString = "ShortCode_block (*args){expresion}" & @CRLF & _
"" & @CRLF & _
"CodeBlock (param1, param2) {" & @CRLF & _
" return param1 + param2" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"no_parenthesis_codeblock {" & @CRLF & _
" # this code block doesnt use parentheses" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")