package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9_]+)\s?(\([a-zA-Z0-9_\s,*]*\))?\s?\{\s?(.*)\s?\}\s?`)
var str = `ShortCode_block (*args){expresion}
CodeBlock (param1, param2) {
return param1 + param2
}
no_parenthesis_codeblock {
# this code block doesnt use parentheses
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}