const regex = new RegExp('([a-zA-Z0-9_]+)\\s?(\\([a-zA-Z0-9_\\s,*]*\\))?\\s?\\{\\s?(.*)\\s?\\}\\s?', 'gm')
const str = `ShortCode_block (*args){expresion}
CodeBlock (param1, param2) {
return param1 + param2
}
no_parenthesis_codeblock {
# this code block doesnt use parentheses
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}